Topics /
Networking & Internet
The most popular blog posts about networking & internet on Hacker News. 64 posts.
Rapid DHCP: Or, how do Macs get on the network so fast?
One of life's minor annoyances is having to wait on my devices to connect to the network after I wake them from sleep. All too often, I'll open the lid on my …
WebSockets RFC is now official
Search IETF mail list archives
Introducing Prompt. Nice SSH for iOS.
In our State of the Union blog post, I mentioned that we’ve been working on some iOS proof of concept / research projects here in the Panic Office. It’s been a lot of fun for us.
The lost Van Jacobson paper that could save the Internet
One of my heroes has always been Van Jacobson. His 1988 paper on solving TCP congestion is an enjoyable read, with cross-discipline appeal. The history of all this is fascinating, such as congestio…
Browser Market Pollution: IE[x] is the new IE6
Feb 2015: 3½ years later, we’re in a better place. The new IE Spartan project has killed off document modes . (Technically, still possible in firewall environments, but… effectively dead for us.) These days, our IE support landscape is IE8 (still), IE11, and IE Mobile. 3 is definitely better than 72.
Iran forged the wrong SSL certificate
If you want to be really evil, however, *.google.com is the wrong SSL certificate to forge. The right one? ssl.google-analytics.com .
GoDaddy's New "Selective DNS Blackouts" Policy
Now that GoDaddy is a near monopoly (larger than the next 8 closest registrar competitors combined 1 ), and just got bought out on July 1, 2011 2 , they have decided they can defy the sacred. Customers be damned.
Own Your Identity
This paragraph in Marshall Kirkpatrick’s Why I’ll Never Redirect my Personal Blog to Google Plus scared me a bit:
Windows 7 Network Awareness: How Windows knows it has an Internet connection
Have you ever been connecting to a new wireless network and seen the following pop-up balloon?
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
SPDY: What I Like About You
I've been working on implementing SPDY as an experiment in Firefox lately. We'll have to see how it plays out, but so far I really like it. ...
DuckDuckGo included in Opera
The Internet privacy company that empowers you to seamlessly take control of your personal information online, without any tradeoffs.
Microsoft Shuts off HTTPS in Hotmail for Over a Dozen Countries
UPDATE (3/26/11): HTTPS is again available for those in the countries discussed below. Microsoft denies deliberately blocking access to HTTPS, blaming the problem on a bug: We are aware of an issue that impacted some Hotmail users trying to enable HTTPS. That issue has now been resolved. Account...
DigiNotar Damage Disclosure (with full list of issued certs)
About an hour ago I was contacted by the Dutch Government with more details about the DigiNotar...
Iran blocks Tor; Tor releases same-day fix
The short version: Tor relays and bridges should upgrade to Tor 0.2.2.33 or Tor 0.2.3.4-alpha so...
IPv6 Day Has Started
SANS.edu Internet Storm Center. Today's Top Story: The Classics Return: Vulnerable E-Mail Scripts;