Topics /

Networking & Internet

The most popular blog posts about networking & internet on Hacker News. 3,019 posts.

Any year
1321

My url isn't your url

When I started the precursor to the curl project, httpget, back in 1996, I wrote my first URL parser. Back then, the universal address was still called URL: Uniform Resource Locators. That spec was published by the IETF in 1994. The term "URL" was then used as source for inspiration when naming the tool and … Continue…

1322

Introducing BitTorrent Torque

Over a decade ago we introduced BitTorrent technology and BitTorrent clients, and the Internet was profoundly changed. This week we are aiming to revolutionize the web once again by integrating the power of BitTorrent with the most familiar experience on a computer: the browser. Today, we are proud to announce the…

1323

Six Years of Gemini

It's been a quiet year at geminiprotocol.net thus far. I've let two "Apollo days" slip by without a word. I'm about as disappointed in myself for this as I expect many folks are unsurprised by it. I do still have plans and clear ideas for finalising the minor oustanding spec issues. I'd tell people to look forward to…

1343

Delayed Messages on iOS

When I got my first iPhone in March I was surprised to find that iMessage didn’t support scheduling messages to be sent at a later time. This feature is pretty common on some other messaging platforms, and it’s especially useful when I remember I need to text my mom (who always has her ringer turned on) about…

1345

Your Chrome browser might not be using HTTP anymore

Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…

1348

Does Your Domain Have a Registry Lock?

If you’re running a business online, few things can be as disruptive or destructive to your brand as someone stealing your company’s domain name and doing whatever they wish with it. Even so, most major Web site owners aren’t taking full advantage of the security tools available to protect their domains from being…