New
The latest blog posts to take off on Hacker News. 8,472 posts.
Speeding up Rails startup time
In which I provide easy instructions to try a new patch that drastically improves the start up time of Ruby applications, in the hope that with wide support it will be merged into the upcoming 1.9.3 release. Skip to the bottom for instructions, or keep reading for the narrative.
How Javascript Prototypal Inheritance Really works
Everywhere on the web we read that Javascript has prototypal inheritance. However Javascript only provides by default a specific case of prototypal inheritance with the new operator. Therefore, most of the explanations are really confusing to read. This article aims to clarify what is prototypal inheritance and how to…
Screw Hashbangs: Building the Ultimate Infinite Scroll
I’m just a student in a field unrelated to computer science , but I’ve been coding for years as a hobby. So, when I saw the current state of infinite scroll , I thought perhaps I could do something to improve it. I’d like to share what I came up with.
You're Using JSON, Why not MessagePack?
JSON is a fantastic format, anywhere people in your organization want to reach for XML, it’s always a good thing to ask the question “Why not JSON?”. The question I’d like you to ask the next time you’re reaching for your JSON hammer, is “Why not MessagePack?”.
TermKit - a graphical terminal replacement
I'm trying to combine WebKit and Node.js into a new kind of terminal, with an emphasis on rich display and web/network orientation.
On HTTP Load Testing
A lot of people seem to be talking about and performing load tests on HTTP servers, perhaps because there’s a lot more choice of servers these days.
IOS RAGE rendered with WebGL
As promised, here's the new WebGL demo that I've been working on! I won't be posting a live version this time (watch the video to find out w...
Google penalizes original content site because of scrapers
In a recent comment someone shared the fate of Patrick Jordan , owner of justanotheripadblog.com.
Ridiculous Things To Do With CSS3 Box Shadows
Box-shadow is a pretty powerful property in modern browsers. With just six little values, you can make some really neat stuff. How much neat stuff, you ask? To find out, I set a little time aside each day to play with it. The result is 39 ridiculous little experiments that, due to whatever issues, can only be viewed…
LastPass Disclosure Shows Why We Can't Have Nice Things
Response to the media's hysteria surrounding LastPass' responsible security warning.
There's more to HTML escaping than &, <, >, and "
This was exaggeration for effect—there aren’t many cases where a simple XSS injection could actually empty a bank account—but I wanted to make a point.
Public key pinning coming in Chrome 13
Starting with Chrome 13, we'll have HTTPS pins for most Google properties. This means that certificate chains for, say, https://www.google.com , must include a whitelisted public key. It's a fatal error otherwise. Credit goes to my colleague, Chris Evans, for much of this.
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
JQuery 1.6 released
jQuery: The Write Less, Do More, JavaScript Library