HTTP/2 Is Done
The IESG has formally approved the HTTP/2 and HPACK specifications, and they’re on their way to the RFC Editor, where they’ll soon be assigned RFC numbers, go through some editorial processes, and be published.
Mark Nottingham's home page
Visit mnot.net → RSS feedOn Hacker News May 2011 – Jul 2026
Networking & Internet 12Web & Frontend 9Society, Policy & Culture 7Systems & Performance 3Security & Privacy 1Life, Learning & Writing 1
The IESG has formally approved the HTTP/2 and HPACK specifications, and they’re on their way to the RFC Editor, where they’ll soon be assigned RFC numbers, go through some editorial processes, and be published.
The Internet Architecture Board (IAB) has published RFC8890, The Internet is for End Users, arguing that the Internet Engineering Task Force (IETF) should ground its decisions in what’s good for people who use the Internet, and that it should take positive steps to achieve that.
The orange site is currently discussing an article about Server-Sent Events, especially as compared with WebSockets (and the emerging WebTransport). Both the article and discussion are well-informed, but I think they miss out on one aspect that has fairly deep implications.
Most of the complexity and nuance of the Web is stuffed into browser engines. Even though they’re a huge burden to develop and maintain, the world is lucky enough to have three major ones, and they’re all Open Source.
Today, the IESG approved publication of “An HTTP Status Code to Report Legal Obstacles”. It’ll be an RFC after some work by the RFC Editor and a few more process bits, but effectively you can start using it now.
Last night, we had a screening of CITIZENFOUR at the IETF meeting in Prague, and about 170 people showed up to see the movie about Edward Snowden’s relevations — information that led the IETF to declare such pervasive monitoring as an attack on the Internet itself.
Don’t use RFC 2616. Delete it from your hard drives, bookmarks, and burn (or responsibly recycle) any copies that are printed out.
One of the changes in Apple’s release of iOS6 last week was a surprising new ability to cache POST responses.
One of the things that came up at the HTTP Workshop was “distributed HTTP” — i.e., moving the Web from a client/server model to a more distributed one. This week, Brewster Khale (of Archive.org fame) talked about similar thoughts on his blog and at CCC. If you haven’t seen that yet, I’d highly suggest watching the…
When to reach for a well-known URI — and the traps that catch most protocol designers.
The Internet Architecture Board (IAB) has published RFC8890, The Internet is for End Users, arguing that the Internet Engineering Task Force (IETF) should ground its decisions in what’s good for people who use the Internet, and that it should take positive steps to achieve that.
When TLS was defined, it didn’t allow more than one hostname to be available on a single IP address / port pair, leading to “virtual hosting” issues; each Web site (for example) now requires a dedicated IP address.
For better or worse, Requests for Comments (RFCs) are how we specify many protocols on the Internet. These documents are alternatively treated as holy texts by developers who parse them for hidden meanings, then shunned as irrelevant because they can’t be understood. This often leads to frustration and – more…
One of the concerns that often comes up when someone creates a new HTTP header is how much “bloat” it will add on the network. This is especially relevant in requests, when a little bit of extra data can introduce a lot of latency when repeated on every request.
What can Apple do in the face of a UK order to weaken encryption worldwide? Decentralize iCloud, to start.
A lot of people seem to be talking about and performing load tests on HTTP servers, perhaps because there’s a lot more choice of servers these days.
RFC 9518: Centralization, Decentralization, and Internet Standards has been published after more than two years of review, discussion, and revision.