New
The latest blog posts to take off on Hacker News. 4,615 posts.
You're Using JSON, Why not MessagePack?
JSON is a fantastic format, anywhere people in your organization want to reach for XML, it’s always a good thing to ask the question “Why not JSON?”. The question I’d like you to ask the next time you’re reaching for your JSON hammer, is “Why not MessagePack?”.
TermKit - a graphical terminal replacement
I'm trying to combine WebKit and Node.js into a new kind of terminal, with an emphasis on rich display and web/network orientation.
On HTTP Load Testing
A lot of people seem to be talking about and performing load tests on HTTP servers, perhaps because there’s a lot more choice of servers these days.
IOS RAGE rendered with WebGL
As promised, here's the new WebGL demo that I've been working on! I won't be posting a live version this time (watch the video to find out w...
Google penalizes original content site because of scrapers
In a recent comment someone shared the fate of Patrick Jordan , owner of justanotheripadblog.com.
LastPass Disclosure Shows Why We Can't Have Nice Things
Response to the media's hysteria surrounding LastPass' responsible security warning.
There's more to HTML escaping than &, <, >, and "
This was exaggeration for effect—there aren’t many cases where a simple XSS injection could actually empty a bank account—but I wanted to make a point.
Public key pinning coming in Chrome 13
Starting with Chrome 13, we'll have HTTPS pins for most Google properties. This means that certificate chains for, say, https://www.google.com , must include a whitelisted public key. It's a fatal error otherwise. Credit goes to my colleague, Chris Evans, for much of this.
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
Why Instapaper Free is taking an extended vacation
Last fall, I conducted an experiment: I quietly removed Instapaper Free from the App Store 1 for three days, leaving only the full, $4.99 Instapaper app . Not only did sales increase incrementally, but nobody seemed to notice.
Tumblr "Disappears" Microsoft's Danah Boyd
Update: Tumblr called me, apologized, and restored my account. More details below.
Finally someone makes sense of JavaScript's this keyword
(In Portugese) The JavaScript this keyword is ubiquitous yet misconceptions abound. What you need to know Every execution context has an associated ThisBinding whose lifespan is equal to that of th…
Actual JavaScript Engine Performance
JSMeter: Measuring JavaScript Behavior in the Wild showed that benchmarks are not representative of the behavior of real web applications. But lacking credible benchmarks, engine developers are tuning to what they have. The danger is that the performance of the engines will be tuned to non-representative benchmarks…
Web development is just broken
No, really, there’s something deeply flawed with web development. And I’m not (just) talking browser incompatibilities, or Ruby vs. Java vs. PHP vs. anything else or about Flash or HTML…
"Diff for HN": Update and highlight changes
Well well well, it's been quite a while! Nice to see you again. Sorry for the delay... I forgot my blog password, and I had to run some errands, the decade just got away from me. Anyway, the password was qwerty123 so let's get on with it...
Emscripten (LLVM-to-JavaScript compiler) 1.0
It's been almost a year since I started Emscripten (which, if you haven't heard of it, is a tool to compile LLVM to JavaScript), during whic...
WebGL + Node.js + WebSockets = A Web Technology Perfect Storm
Tech Nerd. CEO.
Skype 5 for Mac
A while back, when Skype's group videochat feature was still free, a friend of mine sent me a Skype message, asking me whether it was possible to do videochat with more than one person in Skype. "Sure," I replied, "you can do that, but you need to install the new Skype 5 beta." I sent her the link. A few minutes…
How to hide Ryanair
Take a company you have a problem with 1. Imagine you hate Ryanair. I do not btw they are just an example of a company this would work on. 2...