Introducing WebAPI
Mozilla would like to introduce WebAPI with the goal to provide a basic HTML5 phone experience within 3 to 6 months. The current situation Where we are today, there's ...
Mozilla would like to introduce WebAPI with the goal to provide a basic HTML5 phone experience within 3 to 6 months. The current situation Where we are today, there's ...
Miguel de Icaza's Blog
The benefits of customer and agile development and minimum features set are continuous customer feedback, rapid iteration and little wasted code. But over time if developers aren’t careful, code wr…
A work crane at the Clock site in western Texas. There is a Clock ringing deep inside a mountain. It is a huge Clock, hundreds of feet tall, designed to tick for 10,000 years. Every once in a while the … Continue reading →
What's the problem? Here at Google, we have thousands of engineers working on our code base every day. In fact, as previously noted , 50%...
San Francisco - The Electronic Frontier Foundation (EFF) urged a federal court in Colorado today to block the government's attempt to force a woman to enter a password into an encrypted laptop, arguing in an amicus brief that it would violate her Fifth Amendment privilege against self-incrimination...
Today I was chatting with a colleague on Skype, and as is often the case, misspelled something in my rush to get something across. A habit I picked up in the IRC days, days I realize have not...
Paris, November 24th, 2011 — The European Court of Justice just rendered a historic decision in the Scarlet Extended case, which is crucial for the future of rights and freedoms on the Internet. The Court ruled that forcing Internet service providers to monitor and censor their users' communications
That’s right, the CEO of Loopt will personally clean your house for $5. But only if 1,000 people sign up. Only, I haven’t told him about the deal yet. He may not agree, but I’m us…
Lauren Ipsum is trying to get past Jane Hecate, a little old lady who holds the Book of Passwords. Jane is older and can't see well, so she has to spell out Lauren's guess letter by letter to check whether it's the right password. How can Lauren use this to her advantage? A story about computer science and other…
For the next few months I’ll be posting a series of posts on family, startup culture and careers. These vignettes are about how I’ve lived my life trying to make my dent in the universe and trying …
This document contains the release notes for the LLVM Compiler Infrastructure, release 3.0. Here we describe the status of LLVM, including major improvements from the previous release, improvements in various subprojects of LLVM, and some of the current users of the code. All LLVM releases may be downloaded from the…
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
I’m just a student in a field unrelated to computer science , but I’ve been coding for years as a hobby. So, when I saw the current state of infinite scroll , I thought perhaps I could do something to improve it. I’d like to share what I came up with.