The Problem with the iPhone's Home Button
When I posted the link to Andrew Durdin 's visual guide to the iPhone's home button , a number of people sent me messages that basically said "I don't see the problem".
Twitter’s Shit Sandwich
On Twitter’s just-annoucned pan to require third-party clients to use OAuth.
The Tyranny of the Extroverts
Society rewards extroverts. They get the job, the money, the girl (or boy), and the front page. Fortune 500 companies are run by 499 extroverts, plus Bill Gates. There are 435 extroverts in the House of Representatives and 100 in the Senate, two from each state. In fact, the only introvert in the District of Columbia…
WTH is happening to Rails? I'll tell you.
I just read the blog post that got some traction on HN last night, entitled “ What the hell is happening to rails? ” It goes on to list a litany of complaints against changes in Rails 3.x, ranging from the default commenting of the catch-all route to, yes, of course, CoffeeScript. They all end up sounding a lot like…
Aha Moments When Learning Git
Git is a fast, flexible but challenging distributed version control system. Before jumping in: Along with a book, tutorial and cheatsheet, here are the…
Steve Jobs: 1955–2011
I didn’t know Steve. I never met him. I never worked for him. I never even got one of his famous one-liner email responses.
Most laser printer printed pages have tracking watermark
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><a href="http://brahmsyellowdots.blogspot.com/2008/10/it-begins.html">About This Blog</a>
One of the Best Bits of Programming Advice I ever Got
Years ago (early 1992), I attached myself to this crazy skunkworks project that was using this weird language called Smalltalk. "Object Orie...
Microsoft makes 5 times more income from Android than from Windows Phone
Microsoft gets $5 for every HTC phone running Android, according to Citi analyst Walter Pritchard, who released a big report on Microsoft this morning. Microsoft is getting that money thanks to a p…
Miguel de Icaza: Learning Unix
Miguel de Icaza's Blog
Startup Suicide -- Rewriting the Code
The benefits of customer and agile development and minimum features set are continuous customer feedback, rapid iteration and little wasted code. But over time if developers aren’t careful, code wr…
The Clock in the Mountain
A work crane at the Clock site in western Texas. There is a Clock ringing deep inside a mountain. It is a huge Clock, hundreds of feet tall, designed to tick for 10,000 years. Every once in a while the … Continue reading →
Sam Altman will clean your house for $5
That’s right, the CEO of Loopt will personally clean your house for $5. But only if 1,000 people sign up. Only, I haven’t told him about the deal yet. He may not agree, but I’m us…
A little game to demonstrate timing attacks.
Lauren Ipsum is trying to get past Jane Hecate, a little old lady who holds the Book of Passwords. Jane is older and can't see well, so she has to spell out Lauren's guess letter by letter to check whether it's the right password. How can Lauren use this to her advantage? A story about computer science and other…
You'll be dead soon - Carpe Diem
For the next few months I’ll be posting a series of posts on family, startup culture and careers. These vignettes are about how I’ve lived my life trying to make my dent in the universe and trying …
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…