Finally someone makes sense of JavaScript's this keyword
(In Portugese) The JavaScript this keyword is ubiquitous yet misconceptions abound. What you need to know Every execution context has an associated ThisBinding whose lifespan is equal to that of th…
Tower Bridge bot killed by Twitter, replaced with marketing
I got an email today, a bit sad that the bot I made to comment on Tower Bridge's state had disappeared.
"Diff for HN": Update and highlight changes
Well well well, it's been quite a while! Nice to see you again. Sorry for the delay... I forgot my blog password, and I had to run some errands, the decade just got away from me. Anyway, the password was qwerty123 so let's get on with it...
Firefox – tons of tools for web developers
One of the goals of Firefox have always been to make the lives of web developers as easy and productive as possible, by providing tools and a very extensible web ...
It’s the end of the web as we know it
UKOOA offers professional drain unblocking and cleaning services throughout London at a great price. Enquire today for a free quote!
Introducing schema.org: Search engines come together for a richer web
Insights from Googlers into our products, technology, and the Google culture
JavaScript is Not Web Assembly
Writing and Stuff from Isaac Z. Schlueter
WTH is happening to Rails? I'll tell you.
I just read the blog post that got some traction on HN last night, entitled “ What the hell is happening to rails? ” It goes on to list a litany of complaints against changes in Rails 3.x, ranging from the default commenting of the catch-all route to, yes, of course, CoffeeScript. They all end up sounding a lot like…
Introducing WebAPI
Mozilla would like to introduce WebAPI with the goal to provide a basic HTML5 phone experience within 3 to 6 months. The current situation Where we are today, there's ...
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
Screw Hashbangs: Building the Ultimate Infinite Scroll
I’m just a student in a field unrelated to computer science , but I’ve been coding for years as a hobby. So, when I saw the current state of infinite scroll , I thought perhaps I could do something to improve it. I’d like to share what I came up with.
Python For The Web
The Gun.io blog: insights on hiring software developers, AI in engineering, distributed teams and how to build high-performing technical teams.
MemShrink progress report, week 23
The only significant MemShrink-related change that landed this week was that David Anderson removed TraceMonkey , the tracing JIT compiler. In fact, TraceMonkey was disabled a while ago, so the effects on code size and memory consumption of its removal have been felt since then. But it feels more real now that the…
SPDY: What I Like About You
I've been working on implementing SPDY as an experiment in Firefox lately. We'll have to see how it plays out, but so far I really like it. ...
IOS App Store Submission Checklist - anything else to add?
Complete checklist for submitting an iPhone/iPad app to the App Store. An example of the checklist-style of software testing you can do with Testpad. Originally published in 2012. FULLY UPDATED FOR 2018.
Chrome Privacy
Dave Winer ends an otherwise quite reasonable piece about his concern at Facebook's