A bug related to handling of authenticated sessions
On the evening of March 8, we invalidated all authenticated sessions on GitHub.com created prior to 12:03 UTC on March 8 out of an abundance of caution.
Topics /
The most popular blog posts about web & frontend on Hacker News. 8,467 posts.
On the evening of March 8, we invalidated all authenticated sessions on GitHub.com created prior to 12:03 UTC on March 8 out of an abundance of caution.
So last week I was casually browsing through Facebook feed and looking at some random photo posted by a friend. So hovering over the pictur...
It’s been a long-standing dream of front-end developers to have a way to apply CSS to an element based on what’s happening inside that element.
We launched the Datasette Cloud blog today. The Datasette Cloud site itself is a Django app - it uses Django and PostgreSQL to manage accounts, teams and soon billing and payments, then launches dedicated containers running Datasette for each customer.
Performance budgets are an essential but under-appreciated part of product success and team health. Most partners we work with are not aware of the real-world operating environment and make inappropriate technology choices as a result. We set a time budget of less than 5 seconds first-load Time-to-Interactive and less…
Users that are prone to seizures or motion sickness may need to disable animation or motion. Add an option for users to disable this. This…
Almost five years ago to today, I made a simple proposal to the world: Port MAME/MESS to Javascript. That happened. I mean, it cost a dozen people hundreds of hours of their lives…. and there…
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
A few months ago, British Airways' customers had their credit card details stolen. How was this possible? The best guess goes something like this: BA had 3rd party JS on its payment page <script src="https://example.com/whatever.js"></script> The 3rd party's site was hacked, and the JS was changed. BA's customers ran…
V8 now supports BigInts, a JavaScript language feature enabling arbitrary-precision integers.
Imagine you are in an interview and you get asked "can you implement bubble sort"...and you answer...
Jeff Atwood wrote up a post today on the merits of writing a technical book in this day-and-age and specifically called out my past post on programming book profits and my work-in-progress Secrets of the JavaScript Ninja .
I’m just a student in a field unrelated to computer science , but I’ve been coding for years as a hobby. So, when I saw the current state of infinite scroll , I thought perhaps I could do something to improve it. I’d like to share what I came up with.
webpack is a brilliant tool for bundling frontend assets. When things start to slow down, though, its batteries-included nature and the ocean of third-party tooling can make it difficult to optimize. Poor performance is the norm and not the exception. But it doesn’t have to be that way, and so — after many hours of…
At its core, Security Assertion Markup Language (SAML) 2.0 is a means to exchange authorization and authentication information between services. Learn how saml works.
Browse how-to articles on starting, running, and marketing your business, plus thought-provoking podcasts and films to inspire your inner entrepreneur.
I've just finished the final rewrite of my website. I'm not lying: this is the last time I'm ever going to do it. This website has gone through countless rewrites – from WordPress to Jekyll to multiple static site generators of my own – but this is the final one. I know so, because I've found the ultimate method for…
Every time I see a web app display a date as "30 minutes ago" I cringe a little. This was cute 10 years ago when rapid publishing on the web was new, but there are a number of problems with this.
Drilling beneath the hype to expose the truth
We’ve got an important update for the Glitch community today: We’ll be ending web hosting for your apps on Glitch.
WebKit's FTL JIT now uses a new backend on OS X — the Bare Bones Backend, or B3 for short, replaces LLVM as the low-level optimizer.
Creating a full-fledged API requires resources, both time and money. You need to think about the model, the design, the REST principles, etc., without writing a single line of code. Most of the time, you don’t know whether it’s worth it: you’d like to offer a Minimum Viable Product and iterate from there. I want to…
Deno 1.33 is a step towards our next major release, with improved LSP support, enhanced Node.js compatibility, and more.
Download Free PNGs & Free PNG images to use for your creative needs. ✓ Millions of high quality free png images ✓ Transparent pngs ✓ New Free PNGs added everyday.