Topics /

Web & Frontend

The most popular blog posts about web & frontend on Hacker News. 262 posts.

2011
70

WTH is happening to Rails? I'll tell you.

I just read the blog post that got some traction on HN last night, entitled “ What the hell is happening to rails? ” It goes on to list a litany of complaints against changes in Rails 3.x, ranging from the default commenting of the catch-all route to, yes, of course, CoffeeScript. They all end up sounding a lot like…

71

Your Chrome browser might not be using HTTP anymore

Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…

79

Web Intents - the future of web apps

Web Intents is a new project designed to solve the problem of web application integration. Inspired by Android's intent system, it allows developers to build features without needing to integrate with every possible 3rd party service. Web Intents lets users choose their preferred service for actions like image editing…