Topics /

Networking & Internet

The most popular blog posts about networking & internet on Hacker News. 1,615 posts.

Any year
694

My Own DNS Server at Home – Part 1: IPv4

“It’s always DNS” is a famous meme among network people. Name resolution is technically quite simple. It’s “just” translating a hostname like jan.wildeboer.net to an IP address. What could possibly go wrong? I am a radical optimist and detail-obsessed knowledge collector, so I decided to find out. As part of my goal…

696

No need to email me about Cisco AnyConnect

My name and email address can be found in the VPN client application made by Cisco called AnyConnect. They are present there as part of the curl license, because this product - like thousands of others - uses libcurl. My name appears in many products. Apparently, people often have problems finding an appropriate…

697

Exploring the Halo 1 System Link Protocol

One of my all-time favorite games is Halo: Combat Evolved that launched together with the original Xbox in 2001. One major part of the game was multiplayer, up to 16 people at a LAN party could play together by connecting four Xbox consoles over Ethernet , referred to as System Link .

699

Let's Talk About Beacons

Let's Talk About Beacons If you’ve been following the tech scene lately, you may have heard a thing or two about “Beacons”. What are Beacons? Beacons are hardware devices emitting a unique signature...

706

My url isn't your url

When I started the precursor to the curl project, httpget, back in 1996, I wrote my first URL parser. Back then, the universal address was still called URL: Uniform Resource Locators. That spec was published by the IETF in 1994. The term "URL" was then used as source for inspiration when naming the tool and … Continue…

717

Delayed Messages on iOS

When I got my first iPhone in March I was surprised to find that iMessage didn’t support scheduling messages to be sent at a later time. This feature is pretty common on some other messaging platforms, and it’s especially useful when I remember I need to text my mom (who always has her ringer turned on) about…

719

Your Chrome browser might not be using HTTP anymore

Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…

720

Does Your Domain Have a Registry Lock?

If you’re running a business online, few things can be as disruptive or destructive to your brand as someone stealing your company’s domain name and doing whatever they wish with it. Even so, most major Web site owners aren’t taking full advantage of the security tools available to protect their domains from being…