Simple Precision Time Protocol at Meta
While deploying Precision Time Protocol (PTP) at Meta, we’ve developed a simplified version of the protocol (Simple Precision Time Protocol – SPTP), that can offer the same level of clock syn…
Every blog post that took off on Hacker News, ranked by the votes of its best submission. 3,021 posts.
While deploying Precision Time Protocol (PTP) at Meta, we’ve developed a simplified version of the protocol (Simple Precision Time Protocol – SPTP), that can offer the same level of clock syn…
Using the Blurhash algorithm in Mastodon 2.8.1 to generate prettier previews for sensitive media
When I started the precursor to the curl project, httpget, back in 1996, I wrote my first URL parser. Back then, the universal address was still called URL: Uniform Resource Locators. That spec was published by the IETF in 1994. The term "URL" was then used as source for inspiration when naming the tool and … Continue…
Over a decade ago we introduced BitTorrent technology and BitTorrent clients, and the Internet was profoundly changed. This week we are aiming to revolutionize the web once again by integrating the power of BitTorrent with the most familiar experience on a computer: the browser. Today, we are proud to announce the…
It's been a quiet year at geminiprotocol.net thus far. I've let two "Apollo days" slip by without a word. I'm about as disappointed in myself for this as I expect many folks are unsurprised by it. I do still have plans and clear ideas for finalising the minor oustanding spec issues. I'd tell people to look forward to…
Erotic web browser fan fiction.
Press release The Briar Project released version 1.4 of its Android app today. This release adds a couple of new features, highlighted below. First of all, users can now share the app offline. Prior to this release, the only way to get the app was to to download it from the internet, which requires an internet…
WebSockets seem to be gaining a resurgence, suddenly they are sexy again. I think this is the wrong message.
Thoughts on its role and impact on the web’s landscape.
Chrome gets faster as you use it. Chrome learns the topology of the web, browsing patterns, and critical resources on every page to optimize your browsing! A look under the hood of how it all comes together...
By the end of this year Chrome will begin ignoring Flash as Google takes another step towards removing the "final Plugin" by replacing Flash with HTML5.
Altice wins the race to the bottom.
We’ve launched a brand new version of Element, called Element Home!
lol. I minted a new TLS cert and it seems that OpenAI is scraping CT logs for what I assume are things to scrape from, based on the near instant response from ...
Cloudflare is launching an experiment with Chrome to evaluate fast, scalable, and quantum-ready Merkle Tree Certificates, all without degrading performance or changing WebPKI trust relationships.
This blog post is the first part of a series of 3 articles related to the PipeWire project and its usage in embedded Linux systems.
Hello Tor Community! We first introduced you to the Library Freedom Project back in February...
More portable, fully wireless smart home setups. Lower power wearables. Batteryless smart devices. These could all be made possible thanks to a new ultra-low power WiFi radio developed by UC San Diego engineers. It enables WiFi communication at 5,000 times less power than commercial WiFi radios.
As the U.S. Federal Communications Commission prepares to rollback net neutrality protections, the Canadian government has used the controversy to double down on its support for net neutrality safeguards, linking it to democracy, equality, and freedom of expression. I've written several posts on how the U.S. decision…
When I got my first iPhone in March I was surprised to find that iMessage didn’t support scheduling messages to be sent at a later time. This feature is pretty common on some other messaging platforms, and it’s especially useful when I remember I need to text my mom (who always has her ringer turned on) about…
Load balancers are the point of entrance to the datacenter. They are on the critical path to access anything and everything. That give them some interesting characteristics. First, they are the mos…
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
After over 20 years of DNS and PowerDNS, I am moving on. Separate from this page, I am releasing a series of three huge posts on the history of PowerDNS.
If you’re running a business online, few things can be as disruptive or destructive to your brand as someone stealing your company’s domain name and doing whatever they wish with it. Even so, most major Web site owners aren’t taking full advantage of the security tools available to protect their domains from being…