Top posts
Every blog post that took off on Hacker News, ranked by the votes of its best submission. 35 posts.
Rapid DHCP: Or, how do Macs get on the network so fast?
One of life's minor annoyances is having to wait on my devices to connect to the network after I wake them from sleep. All too often, I'll open the lid on my …
The lost Van Jacobson paper that could save the Internet
One of my heroes has always been Van Jacobson. His 1988 paper on solving TCP congestion is an enjoyable read, with cross-discipline appeal. The history of all this is fascinating, such as congestio…
Browser Market Pollution: IE[x] is the new IE6
Feb 2015: 3½ years later, we’re in a better place. The new IE Spartan project has killed off document modes . (Technically, still possible in firewall environments, but… effectively dead for us.) These days, our IE support landscape is IE8 (still), IE11, and IE Mobile. 3 is definitely better than 72.
Iran forged the wrong SSL certificate
If you want to be really evil, however, *.google.com is the wrong SSL certificate to forge. The right one? ssl.google-analytics.com .
GoDaddy's New "Selective DNS Blackouts" Policy
Now that GoDaddy is a near monopoly (larger than the next 8 closest registrar competitors combined 1 ), and just got bought out on July 1, 2011 2 , they have decided they can defy the sacred. Customers be damned.
Own Your Identity
This paragraph in Marshall Kirkpatrick’s Why I’ll Never Redirect my Personal Blog to Google Plus scared me a bit:
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
SPDY: What I Like About You
I've been working on implementing SPDY as an experiment in Firefox lately. We'll have to see how it plays out, but so far I really like it. ...
Why is it so hard to be a good domain registrar?
I recently moved all of my domains away from GoDaddy, because they’re terrible. 1
Google Voice Now Offers SIP Addresses For Calling Directly Over IP
Wouldn't it be great if you could call a Google Voice number directly via SIP? So that you could bypass the PSTN when calling a GV number and go directly over IP? With potentially all the advanced capabilities that could give? (wideband audio, video, etc.) It turns out that you now can !
World Domination Using Arduinos and Websockets
Arduino Websocket Client Arduino Pusher Client Pusher – Real Time Push Notifications Follow Me On Twitter: @kevinrohling If you don’t have your very own Arduino yet you should get one. …
Searching for "semicolon injection" bugs in embedded Linux devices
Introduction I recently bought a D-Link DCS-2121 surveillance camera. This is good stuff: Megapixel camera + microphone + speaker WiFi,...
Starcraft Network
I’ll cut right to the chase: my network naming convention is spectacular. I highly suggest emulating it.
Port 25 will be blocked for South Korea from December
Oh, boy has it been quiet here. I have used wayback machine to pull a bunch of older content into the repo so that it can be shared with you beautiful people. There was no real reason to do that except I get annoyed by broken links. Really annoyed. It seems every time I reach back into my bookmarks for something the…