Set up an email server in two hours
You may be concerned that the NSA is reading your e-mail. Is there really anything you can do about it though? After all, you don’t really want to move off of GMail / Google Apps. And no plac…
Every blog post that took off on Hacker News, ranked by the votes of its best submission. 1,615 posts.
You may be concerned that the NSA is reading your e-mail. Is there really anything you can do about it though? After all, you don’t really want to move off of GMail / Google Apps. And no plac…
Update: 28 Nov 2023 Zen Internet and I have amicably parted ways over this matter. Their technical response has been added to this post.
“It’s always DNS” is a famous meme among network people. Name resolution is technically quite simple. It’s “just” translating a hostname like jan.wildeboer.net to an IP address. What could possibly go wrong? I am a radical optimist and detail-obsessed knowledge collector, so I decided to find out. As part of my goal…
Solving a boot-time power challenge on PoE+ x86 systems by creating our own UEFI app to handle LLDP power negotiation at the firmware level, allowing our machines to request higher power from network switches before the OS loads.
My name and email address can be found in the VPN client application made by Cisco called AnyConnect. They are present there as part of the curl license, because this product - like thousands of others - uses libcurl. My name appears in many products. Apparently, people often have problems finding an appropriate…
One of my all-time favorite games is Halo: Combat Evolved that launched together with the original Xbox in 2001. One major part of the game was multiplayer, up to 16 people at a LAN party could play together by connecting four Xbox consoles over Ethernet , referred to as System Link .
Let's Talk About Beacons If you’ve been following the tech scene lately, you may have heard a thing or two about “Beacons”. What are Beacons? Beacons are hardware devices emitting a unique signature...
Four billion phones ask one text file what time it is, kept by a UCLA lecturer in his spare time. We counted who maintains the code under your phone.
When you read up on the DisplayPort connector in the VESA specification, it will show that both the source and the sink are supposed to provide power at 3.3V+-10% and 500mA on the DP_PWR pin, pin 20, of the connector.
How I detected that Let's Encrypt issued 645 non-compliant certificates
The internet is big. Really big . You just won’t believe how vastly, hugely, mind-bogglingly big it is. I mean, you may think the /22 you got as a LIR was big, but that’s just peanuts to the internet.
When I started the precursor to the curl project, httpget, back in 1996, I wrote my first URL parser. Back then, the universal address was still called URL: Uniform Resource Locators. That spec was published by the IETF in 1994. The term "URL" was then used as source for inspiration when naming the tool and … Continue…
Erotic web browser fan fiction.
WebSockets seem to be gaining a resurgence, suddenly they are sexy again. I think this is the wrong message.
Thoughts on its role and impact on the web’s landscape.
Chrome gets faster as you use it. Chrome learns the topology of the web, browsing patterns, and critical resources on every page to optimize your browsing! A look under the hood of how it all comes together...
Altice wins the race to the bottom.
lol. I minted a new TLS cert and it seems that OpenAI is scraping CT logs for what I assume are things to scrape from, based on the near instant response from ...
As the U.S. Federal Communications Commission prepares to rollback net neutrality protections, the Canadian government has used the controversy to double down on its support for net neutrality safeguards, linking it to democracy, equality, and freedom of expression. I've written several posts on how the U.S. decision…
When I got my first iPhone in March I was surprised to find that iMessage didn’t support scheduling messages to be sent at a later time. This feature is pretty common on some other messaging platforms, and it’s especially useful when I remember I need to text my mom (who always has her ringer turned on) about…
Load balancers are the point of entrance to the datacenter. They are on the critical path to access anything and everything. That give them some interesting characteristics. First, they are the mos…
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
If you’re running a business online, few things can be as disruptive or destructive to your brand as someone stealing your company’s domain name and doing whatever they wish with it. Even so, most major Web site owners aren’t taking full advantage of the security tools available to protect their domains from being…