There's more to HTML escaping than &, <, >, and "
This was exaggeration for effect—there aren’t many cases where a simple XSS injection could actually empty a bank account—but I wanted to make a point.
The latest blog posts to take off on Hacker News. 398 posts.
This was exaggeration for effect—there aren’t many cases where a simple XSS injection could actually empty a bank account—but I wanted to make a point.
Starting with Chrome 13, we'll have HTTPS pins for most Google properties. This means that certificate chains for, say, https://www.google.com , must include a whitelisted public key. It's a fatal error otherwise. Credit goes to my colleague, Chris Evans, for much of this.
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
jQuery: The Write Less, Do More, JavaScript Library
Last fall, I conducted an experiment: I quietly removed Instapaper Free from the App Store 1 for three days, leaving only the full, $4.99 Instapaper app . Not only did sales increase incrementally, but nobody seemed to notice.
Update: Tumblr called me, apologized, and restored my account. More details below.
(In Portugese) The JavaScript this keyword is ubiquitous yet misconceptions abound. What you need to know Every execution context has an associated ThisBinding whose lifespan is equal to that of th…
JSMeter: Measuring JavaScript Behavior in the Wild showed that benchmarks are not representative of the behavior of real web applications. But lacking credible benchmarks, engine developers are tuning to what they have. The danger is that the performance of the engines will be tuned to non-representative benchmarks…
The world of online video is incredibly complex and dynamic. Yet, our goal is to ensure that nothing stands between you and the great content you’ve always enjoyed. We’ll continue to invest in new video technology that improves the experiences for all users, builds a better infrastructure for online video, leads to…
No, really, there’s something deeply flawed with web development. And I’m not (just) talking browser incompatibilities, or Ruby vs. Java vs. PHP vs. anything else or about Flash or HTML…
Well well well, it's been quite a while! Nice to see you again. Sorry for the delay... I forgot my blog password, and I had to run some errands, the decade just got away from me. Anyway, the password was qwerty123 so let's get on with it...
It's been almost a year since I started Emscripten (which, if you haven't heard of it, is a tool to compile LLVM to JavaScript), during whic...
Tech Nerd. CEO.
jQuery: The Write Less, Do More, JavaScript Library
A while back, when Skype's group videochat feature was still free, a friend of mine sent me a Skype message, asking me whether it was possible to do videochat with more than one person in Skype. "Sure," I replied, "you can do that, but you need to install the new Skype 5 beta." I sent her the link. A few minutes…
Mozilla, a global, nonprofit organization dedicated to making the Web better, is excited to release Mozilla Firefox 4 for Android. Firefox delivers an intu