New
The latest blog posts to take off on Hacker News. 1,905 posts.
Machine Learning: A Love Story
The video from my keynote at Strange Loop 2010 is up! You can watch the video here: Machine Learning: A Love Story The original abstract: Machine learning has come a long way in recent years — from…
Why linux doesn't have a "wheel" group
The wheel group is, perhaps, not widely used today, or is seen as “archaic” and irrelevant. Nothing could be further from the truth. The wheel group is a group which limits the number o…
DHS asks Mozilla to take down MafiaaFire add-on
From time to time, we receive government requests for information, usually market information and occasionally subpoenas. Recently the US Department of Homeland Security contacted Mozilla and reque…
British hackers: stop voting for lizards; start voting for people today
In So Long and Thank for All The Fish, the elegiac fourth book of the Hitch Hiker’s Guide to the Galaxy Trilogy, Douglas Adams gives us this conversation between Arthur, a very ordinary Earth…
The story of George — ayttm's most prolific non-developing contributor
The last communication I had from George was in September 2008. He had helped with tons of little improvements in ayttm, like auto-complete, spell check, etc in addition to affecting the big changes. He is responsible for the rewrite of the msn plugin too. I tried getting back in touch in October for his suggestions…
Public key pinning coming in Chrome 13
Starting with Chrome 13, we'll have HTTPS pins for most Google properties. This means that certificate chains for, say, https://www.google.com , must include a whitelisted public key. It's a fatal error otherwise. Credit goes to my colleague, Chris Evans, for much of this.
The Last Post
Here it is. I'm dead, and this is my last post to my blog. In advance, I asked that once my body finally shut down from the punishments of my cancer, then my family and friends publish this prepared message I wrote—the first part of the process of turning this from an active website to an archive.
Your Chrome browser might not be using HTTP anymore
Tim Berners-Lee rightfully deserves all the credit for his early work around URI, HTTP and HTML. His efforts ultimately led to the official HTTP 1.0 ( RFC 1945 ) specification in 1996, the HTTP 1.1 proposal (RFC 2068) in 1997 and consequently the official HTTP 1.1 spec ( RFC 2616 ) in 1999. The web as we know it…
De-anonymizing Apple UDIDs with OpenFeint
Every iPhone, iPad and iPod touch has an associated Unique Device Identifier (UDID). You can think of the UDID as a serial number burned into the device - one that can't be removed or changed 1 . This number is exposed to app developers through an API, without requiring the device owner's permission or knowledge.
John Resig joins the Khan Academy
Today I’m announcing a major change in my life: I’m leaving Mozilla Corporation and joining Khan Academy .
I take illegal drugs for inspiration
I take illegal drugs for inspiration Daily Telegraph, Saturday May 21st 2005, pp 17-18 (Note: This version is very slightly different from the published, edited, version) © Sue Blackmore 2005 Every year, like a social drinker who wants to prove to herself that she’s not an alcoholic, I give up cannabis for a month. It…
The 10 commandments of good source control management
Ah source control, if there’s a more essential tool which indiscriminately spans programming languages without favour, I’m yet to see it. It’s an essential component of how so many of us work; the lifeblood of many development teams, if you like. So why do we often get
How I Turned Down $300,000 from Microsoft to go Full-Time on GitHub
2008 is a leap year. That means that three hundred and sixty six days ago, almost to the minute, I was sitting alone in a booth at Zeke’s Sports Bar and Grill on 3rd Street in San Francisco. I wouldn’t normally hang out at a sports bar, let alone a sports bar in SOMA, but back then Thursday was “I Can Has Ruby” night…
Softlayer Cloud: An operations guy's rant about really bad service
Disclaimer: the information in this post is the author’s personal opinion and is not the opinion or policy of his employer. It was spring 2010 when we decided that even though Softlayer‘s server provisioning system is really great and it takes only a few hours to get a new server when we need it, it […]
Smaller than Bloom filters
I've been looking at what would be needed in order to have a global view of CRLs in browsers. At the moment revocation has three problems: privacy (by asking the CA about the status of a certificate you're revealing to them what you're looking at), performance (OCSP checks take hundreds of milliseconds which adds up…
An open letter to Mike Arrington: Please stop investing in startups
Hi Mike, I’m one of your customers. We don’t really know each other. We’ve chatted at a few events, you’ve covered some of my antics, but I’m mostly just a guy who reads TechCrunch a lot. I find it’s a pretty good place to see what’s important in the industry. And you and your team do some damn fine reporting on…
Startups Are Hard
Contrary to popular belief, there are no clouds of money that float around Silicon Valley and rain on anyone that utters the phrase, "I'm a founder!" Unfortunately, starting a company and raising money is just as hard as ever; it's just that the investors don't have as much leverage as they used to, but they still…
Google's Backdoor Access System into Gmail Accounts
Google made headlines when it went public with the fact that Chinese hackers had penetrated some of its services, such as Gmail, in a politically motivated attempt at intelligence gathering. The news here isn’t that Chinese hackers engage in these activities or that their attempts are technically sophisticated—we knew…
The context sensitivity of C's grammar
Context free grammars (CFGs) are a valuable theoretical tool on which the modern compilation theory relies for parsing the code of programming languages. For example, the most popular tool used for parsing – YACC , generates parsers for CFGs. What most people don’t know 1 is that the vast majority of programming…